Saturday, December 29, 2012

Wouxun KG-UVD1P: Display Problem

So I had been using the KG-UVD1P as my mobile rig (video here). Over time, the heat in the car must have taken its toll on the radio as the display does not work. I'm not the only one who has had this problem. Sorry for the poor iPhone video, but there isn't much to show, so I think it will suffice.

 

7 comments:

  1. Oops... bummer. No problems here (yet). Did you contact Wouxun or your dealer?

    ReplyDelete
    Replies
    1. I've not. I found that one link, but have not seen many others with the problem. I'm thinking about cracking it open to have a look-see.

      Delete
  2. Maybe the display moved a bit so that is makes no good contact..?

    ReplyDelete
  3. BTW, you don't have any info on your site about the new and excellent Baofeng UV-B5 radio that Hans reviewed on his site.

    ReplyDelete
    Replies
    1. Funny thing... I've had the tab open to his page and it keeps moving to the back for no good reason. Now I've got work problems... waiting on a response from Oracle. Woo. Hoo. :(

      Delete
  4. If the display is locked and no menu ability, you must just:

    -ERASE ALL THE MEMORIES from the tranceiver with the DATA CABLE and a PC software (it works!).

    -You reboot it, and ERASE ALL THE MEMORIES AGAIN with the menu from the KG-UVD1P

    And it's finish, your KG-UVD1P is OK to do the next QSO! :-)

    ReplyDelete
    Replies
    1. No joy on the display problem after a reset.

      Delete